How to do replacer vanilla scars

Create scars by replacing vanilla one

Summary

Published: Feb 05 2024 by Yggnire, initial guide by Yggnire Last documented edit: Feb 05 2024 by Yggnire

This guide will teach you how to create scars by replacing vanilla one. In this guide, we'll replace #4 in the Character Customization.

Level of difficulty

The ability to read: mandatory, because I'm not gonna lie โ€” this is gonna be difficult otherwise. Knowing how to use a drawing software : recommended, because this guide will not cover it.

Expected time to complete

<5 minutes to set up everything 5 minutes - s long as it takes you to create a scar that you like <5 minutes for the import/install

Prerequisites

Step 1: Settings up

  1. To create scars replacer, you need the following files (they're shared for both body genders) from this folder:

base/characters/common/character_customization_items/scars/face/textures
files name

- h0_000_pma__basehead_scars_d01

- h0_000_pma__basehead_scars_d02

- h0_000_pma__basehead_scars_m01

- h0_000_pma__basehead_scars_n01

  1. Add the files to your project by double-clicking

  2. Open all of them on a drawing software like photoshop, clip studio paint or photopea.com

Step 2: Scar creation :

Let's start by creating the scar's bumpmap. Open pma__basehead_scars_n01.png (the yellow-greenish one).

The image should look like this :

The vanilla size are 1024x1024, I have upscaled mine to 4096x4096, but that's personal taste.

  1. You will need to erase one of the pre-existing scars. Use the pipette tools and take the same color as the background.

  1. Add a new layer and paint over this part of the image.

By creating a new layer, you will preserve the original edit and can toggle your changes on and off in the layers palette.

  1. Once itโ€™s done, add a new layer and start to draw your scar, I recommend you to use a brush similar to wet watercolor to create ยซ natural scars ยป if you want to create cyberware scar, use a more consistent brush .

The scar replaced spans the entire face, so this is the best scar to replace. To see which parts are affected, you can drag the _d texture on your mesh and turn its opacity to 50%:

  1. To create your scar, take a basic red color, and draw your scar on the new layer you created in Step 2.

  2. Copy the entire layer (Hotkey: Ctrl+A, Ctrl+C)

  3. In the Layers Palette, select the red channel and paste your scar. The image will now be black and white.

  1. In the Layers Palette, select all three channels (or RGB) to see colours again.

  2. Now you need to turn your image green. There are various ways to do that, for example Image -> Adjustments -> Hue/Saturation.

  3. Copy the green scar and paste it into the green channel.

  4. Use CTRL + T to select it and shifted the scar a few pixels to the right (you can use the arrow keys). It should now look like this:

Editing the roughness map

  1. Now that you have a scar, open h0_000_pma__basehead_scars_m01 (the black-and-white one, your metallic map).

  2. On the yellow image, switch to the red channel again and copy everything (Hotkey: Ctrl+A, Ctrl+C)

  3. Paste it into the metallic image (Hotkey: Ctrl+V). It should now be on another layer. If not, undo the paste (Hotkey: Ctrl+Z), create a new layer in the layer palette, and paste it again.

  4. The pasted scar should automatically be black and white. If not, change that via the Edit -> Image -> Greyscale option.

  5. Invert the image (Hotkey: Ctrl+I) so that it looks like the picture below:

  1. Now change the contrast of the formerly red channel so that the scar is black (Image -> Adjustments -> Brightness/Contrast).

  2. Repeat the process with the green channel from the normal map.

  3. Now change the brightness of the formerly green channel to a light grey Image -> Adjustments -> Brightness/Contrast).

  4. Set the blending mode of the green scar layer to Difference. This will give you an inverted image, but that's fine.

  5. Now, merge the two layers (hotkey: Ctrl+E)

  6. Invert it (Hotkey: Ctrl+I)

  7. Change the tint of the RED scar to black and the GREEN one to light grey.

Do this for the others png files with appropriate colors.

Replace in your wolvenkit project all the png with the new one, ยซ Import ยป and then ยซ Install ยป and enjoy your new scar !

Go to Character Customization and select the scar 4.

Known issue :

Here is the issue that I have had to deal with and you will certainly meet it.

In-game, this kind of issue can happen , nose textures cut and strange square shadow on the neck.

To remedy this problem, create a new project and obtain the 4 file types as seen above and replace them with those that you modified, export, import, install and that's it, the problem should no longer be present. If the problem persists, start the procedure again.

Last updated