Actions
The Actions category within the Ribbon

What is the Actions tab?

The functionality of the Actions tab is context-sensitive, unlike other areas of the Ribbon. The content of the Action tab will vary based on which editor window is currently selected. For instance, while the Project Explorer is selected operations for deleting files become available within the Actions tab.

Project Explorer Actions

File Tab

Open

Opens REDengine files with the File Editor

Copy

Copies any file within the Project Explorer to clipboard

Paste

Pastes any file within the Project Explorer to the selected destination. Duplicate files will be renamed using traditional Windows conventions.

Delete

Deletes any file within the Project Explorer. (The recycle bin will be used unless turned off within Windows settings).

Rename

Opens a dialogue box to rename any file within the Project Explorer

Open in File Explorer

Locates selected object within the Project Explorer using the external system file explorer

Simple Export

Not implemented

Advanced Export

Not implemented

View Tab

Expand all folders

Expands all folders within the Project Explorer

Collapse all folders

Collapses all folders within the Project Explorer

Expand Children

Expands child folders based on selection within the Project Explorer

Collapse Children

Collapses child folders based on selection within the Project Explorer

Asset Browser Actions

Search Tab

Search Options

<text>

Open File Location

Open the real containing folder of the selected file within the Asset Browser

File Tab

Add Selected Item(s) to Project

Items selected within the Asset Browser will be added to the Mod directory of the Project Explorer

Toggle Mod Asset Browser

Switch between vanilla and user-generated archives on the fly. Mod archives must be installed to the game directory within the Settings page.

View Tab