Troubleshooting

Fixes to common problems

I receive an error saying 'Unknown Version'

Please ensure the following:

  1. If you have modified your game's .exe file yourself, the mod will not work - to undo this, delete the file and verify your game through GOG, Steam or Epic to download a fresh copy of the newest exe.

  2. You are using a patch that is not supported (currently only 1.30 is supported).

  3. You used the old version of the mod and still have the old files installed. Delete bin/x64/plugins/ and reinstall the mod.

No log file appears in bin/x64/plugins/cyber_engine_tweaks/!

Install this - if nothing happens, please make sure all of your overlays and monitoring programs are disabled. There is a list of known programs that cause issues below. If you find one not on the list, contact Arsenic_Touch via the discord.

I don't have a config file in bin/x64/plugins/cyber_engine_tweaks/!

Cyber Engine Tweaks no longer comes with a config file, one is generated when you first launch the mod.

The CET window will not close.

When first launching cyber engine tweaks, it will prompt you to pick a keybind. Tilde is no longer the default.

When I press the key to show the console, I only see the cursor!

Certain programs conflict with the hook that Cyber Engine Tweaks use to display the console - to avoid this, disable any software with overlays that may impact the mod (some examples below). This includes crashing the game or not launching at all. OBS graphics-hook32.dll and graphics-hook64.dll can also interfere. Do a search of your windows files to see if you have a program running them. For rivatuner, you can also open the Global file, which is located in RivaTuner Statistics Server\ProfileTemplates and add cyber_engine_tweaks.asi to the end of the decimal in the line: InjectionDelayTriggers

  1. ​AMD Radeon ​

  2. ​Discord​

  3. ​Geforce Experience​

  4. ​Steam​

  5. ​XBOX Game Bar​

  6. ​MSI Afterburner ​

  7. ​Rivatuner​

  8. ​GoG Galaxy​

  9. ​Epic​

  10. ​NZXT Cam​

  11. ​Ubisoft Connect​

Cyberpunk crashes after the intro video when using CET 1.14

  1. Open Windows Security

  2. Go to Apps & Browser control on the left tabs

  3. Click Exploit protection settings Under the Exploit Protection section

  4. In the Systems Settings tab locate Randomize memory allocations (Button-up ASLR) and High-entropy ASLR and change their settings to Use default (On).

  5. Restart your computer.

Credit to discord user @rachmanov1c @OrBy

The mod isn't working with my version of the game!

Please verify that:

  1. Your version of Cyberpunk is compatible with the newest release on GitHub or Nexus (this can be seen in the menu, underneath "Quit Game")

  2. You have the most recent version of the mod from GitHub or Nexus.​

  3. The installation guide has been followed correctly

  4. You have verified that the log found in bin/x64/plugins/cyber_engine_tweaks/cyber_engine_tweaks.log is 'last modified' at the same time and date as your most recent attempt to launch the game

  5. Remove all previous mods in the mods folder and try to launch the game. If it works, add your mods back one by one until you find the one that breaks CET. Some mods can break CET completely or change the overlay colour if they are not up to date.

If installed through vortex and your game won't launch.

  1. Make sure cyber engine tweaks and your mods are installed with hardlink deployment If hardlink doesn't show up under vortex, make sure the Vortex Mods folder is on the same partition as the game mods folder. This explains it more.

The prompt to choose a keybind doesn't appear and or pressing the chosen keybind does not bring up the mod.

There are six possible solutions to this:

  1. Ensure your game is in Windowed Borderless mode - Cyberpunk will usually make itself the topmost application on your screen if in fullscreen.

  2. Ensure you don't have any overlay or monitoring software running such as Rivatuner, Fraps, etc.

  3. Make sure your game is up to date and you are using the latest version of Cyber Engine Tweaks and that you installed it properly. (do a clean install by deleting the plugins folder, LICENSE, global.ini, version.dll files if you are running into a problem)

  4. Run the game as administrator. (this works for some people where other methods have failed)

  5. Check to make sure your antivirus software is not removing or blocking cyber engine tweaks.

  6. Do a complete reinstall of cyberpunk 2077.

I forgot the keybind to bring up the overlay for CET.

  1. Delete the hotkeys.json and config.json files located inbin/x64/plugins/cyber_engine_tweaks/ and start your game, the overlay to choose a new keybind should come up.

Submitting an issue

Please ensure you attempt deleting and reinstalling the mod before submitting an issue! Alternatively, consider asking in the Discord server. Additionally, please check to ensure your issue has not already been reported!

If you cannot find your problem listed, submit an issue on GitHub with the following:

  • Your configuration file

  • Your Cyber Engine Tweaks version and your Cyberpunk 2077 version

  • Your log file

  • Your OS version

  • A description of your issue