MLSETUP Builder

The tool of your choice for editing multilayered materials

Summary

Published: ??? by manavortex Last documented update: Jan 20 2024 by manavortex

This page will teach you how to download and configure MLSetupBuilder, the tool of choice to edit multilayered materials in Cyberpunk.

At the bottom of the page, you will find Video Guides. Keep in mind that they are outdated.

MLSB <= 1.6.8 does not include a full material preview. The 3d view will only show you which parts of a mesh are affected by your material. If you want to preview a material in colour, you'll have to do this in Blender โ€” use the Wolvenkit Blender IO Suite's mesh import.

Wait, that's not what I want!

Introduction: What is MLSB?

MLSetupBuilder (commonly referred to as "MLSB") is a Cyberpunk 2077 modding tool to comfortably edit MLSetup files, developed and maintained by Neurolinked.

There is a dedicated channel on the Redmodding Discord and a thread on the Cyberpunk 2077 Modding Discord Server, where you can find a chat history full of (yet) undocumented features, along with previews and videos of the most recent development versions.

Installation

For integration with Wolvenkit, install MLSB as a plugin:

  1. Click on "Home" in Wolvenkit's title bar

  2. Select "Plugins" in the left sidebar

  3. If MLSB is installed, you'll see an "Update" button, otherwise, it will say "Install". Do that.

  4. If that doesn't work for any reason, you can install it by hand: download the latest release from Neurolinked's github and extract the files to following subfolder in your Cyberpunk game directory (the number must be the same as displayed in the WKit plugin list) Cyberpunk 2077\tools\neurolinked\mlsetupbuilder\MlsetupBuilder-1.6.7

We will now launch MLSB and do the initial setup.

  1. In Wolvenkit's Plugin view, click "Open", this will open a Windows Explorer with the install folder (Cyberpunk 2077\tools\neurolinked\mlsetupbuilder)

  2. Navigate to the folder with the higest version (at the time of this guide, that is MlsetupBuilder-1.6.7)

  3. Start MlsetupBuilder.exe

  4. Optional: You can pin that file to your start menu or create a shortcut if you want to launch MLSB directly.

For MLSetupBuilder

Usage

To make the most of MLSB's features, you will want to configure it first. However, you can start using the tool right away.

Here's how (or scroll down for the screenshot):

  1. Right-click on the newly created mlsetup.json file

  2. Select "Open in MLSetupBuilder"

Using MLSB

As of Version 1.6.7, this is what you will see now:

Start by importing the file from the preview. That will populate the Layer Config box with the MLSetup that you just loaded.

The preview was hiding an empty 3d viewport. To use that, you will need to configure MLSB first, but you can already click through the individual layers and assign material properties (such as roughness, normal strength, base material and colour) from the "Material Properties" panel.

Don't forget to hit "Apply" after you have changed a material.

Once you're done:

  • select File -> Export

  • overwrite the original mlsetup.json

  • switch back to Wolvenkit

  • in the "raw" folder, right-click on your file

  • select "Import/Convert from JSON"

Congratulations โ€” you now have an .mlsetup! If you pack your mod and launch the game, you should now see your changes.

Functions

There are 3 important functions to note:

  1. Materials: this manages the tiles, opacity, offset, and roughness of the texture.

  1. Color: this manages color and luminosity of the texture.

  1. ยตblend: this manages the pattern and acts as a secondary, tiled normal map. Additionally, the contrast value can be used to block out parts of the layer to create patterns.

You can only use microblends if this layer's mask is not fully white.

Note

After any edits, make sure to Apply edits to save progress and complete changes to any/all functions (Hotkey: Ctrl+Shift+A)

Layers

Each and every layer is attached to its own Multilayer layer when converted from .json to .mlsetup. When adding new layers, ensure designating intended functions for each layer as part of the larger Multilayer inside WolvenKit.

About That 3d Viewport

This is where you can load models from the game for a direct preview which layer will affect which parts: simply click on the "Library" button.

MLSB Library

Here, you can either browse to your model directly, or use text search:

After selecting a model, you can close the library browser again. Now selecting a layer will show you directly which parts of the mesh it corresponds to.

That's it! Happy recoloring!

Other Tools inside MLSB

Inside MLSB there are some other tools, the most important one is the Material Composer.

From this window you can import and export .Material.json files ( these files are exported by Wolvenkit with the WithMaterial option). You can edit the materials parameters, adding material or removing them from the material file. Material templates found in the .Material.json file can be put in the Library and then used later for another edit of materials of a completely different mesh. You can duplicate entries just changing the name of the material and putting them in the buffer again (that's what i did to have 10 different material colors that comes for the glass material of the Kendachi Monokatana mod). Material Composer will also display all the material parameters that comes with the material template (materials baked by the CDPR system have their parameters hidden if they were left as default before the baking of the release).

Configuration

Connecting to Wolvenkit

We're assuming that you have already configured Wolvenkit. If you haven't, please do so now.

Requirements: Getting the CLI

In MLSetupBuilder 1.6.7, select the menu Help -> download Wolvenkit.CLI and extract the linked version:

In MLSB >= 1.6.8, download the most recent version of WolvenKit Console and extract it to a folder of your choice.

  1. Now, switch to MLSetupBuilder.

  2. Select "File -> Preferences"

  3. Apply the following settings:

Game folder v1.6.7

C:\Your\Path\To\Cyberpunk 2077\archive\pc\content

Game folder v1.6.8

C:\Your\Path\To\Cyberpunk 2077

uncook folder

You can find this folder in your WolvenKit's settings as "Depot Path" (you've seen it in the window from Step 1)

Wolvenkit Depot Path

You can find this folder in your WolvenKit's settings as "Depot Path" (you've seen it in the window from Step 1)

Wolvenkit-CLI.exe

The executable of Wolvenkit Console from Step 2, You can download the last compatible and tested CLI from inside MLSB going in the menu Help > Download Wolvenkit.CLI

  1. Press Ctrl+R to reload MLSB and make sure that the settings are applied.

Building the depot

Again, this step is optional, you can use MLSB straight away.

  1. Open the menu "Build" and select "Repository" to uncook the archives:

  1. Select the following settings (if you want to uncook everything, this step can take several hours, so we'll only do the essentials for now)

  1. Click "Uncook".

  2. Wait. Do not interact with the program in any way until the process has finished - especially interacting with the console might just freeze up the entire windows cmd process. This is not MLSB's fault, but due to a Windows standard implementation.

This process can take some time โ€” if you have selected everything, it can be several hours on slow machines. (You should've listened during step 1, choomba ;))

  1. When the process is complete, close the Depot Generator window.

  2. Optional: if you can't see any changes, press Ctrl+R to relaod MLSB.

Building the Microblend Depot

  1. Repeat Step 1 from #extract-a-partial-depot, but select Microblends this time

  2. In the bottom left corner, hit "Start"

  3. Wait.

  4. When the process is complete, close the Depot Generator window.

  5. Optional: if you can't see any changes, press Ctrl+R to relaod MLSB.

That's it, you're done now and can use the 3d viewport!

Troubleshooting

Generic troubleshooting

Close MLSB, then open %APPDATA%\Mlsetupbuilder\config.json in a text editor and decrement the version by one (e.g. 1.6.8 => 1.6.7). This will force MLSB to re-check its settings.

Alternatively, you can also delete the file and reconfigure.

Generating microblends: [ 0: Error ] - Please fill in an output path

For MLSB <= 1.6.7, you have to use the exact CLI version you find under Help -> Download Wolvenkit.CLI

Help, my Layer Config List says object Object

You need to install the most recent version. If that doesn't make the error go away and your most recent version is something with 1.6.7, update the interface.js โ€” download it here from Neurolinked's github repository, then replace the file with the same name in MLSB's install directory, subfolder resources\app\js.

If you have installed it as a Wolvenkit plugin, that directory will be Cyberpunk 2077\tools\neurolinked\mlsetupbuilder.

There's an exception when generating my depot!

Does the progress bar still move? If yes, then you're good - ignore this.

If not, you haven't left your fingers off MLSB and need to start over. Click "Uncook", then go afk until it's done.

If that doesn't help either, it's worth trying Wolvenkit Console's latest Nightly.

Video Guides

Please keep in mind that these guides are seriously outdated. If things don't look as expected, check this guide, which is much more up-to-date, or find help on Discord (link in Introduction: What is MLSB?)

Credits to EzioMavericks for the video

Last updated